Convert dds to png: Mixed pixels and unexpected end-of-file

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
Posts: 1
Joined: 2012-12-12T01:00:38-07:00
Authentication code: 6789

Convert dds to png: Mixed pixels and unexpected end-of-file

Post by noxx000 »


Not sure if this is some kind of bug, miss-specification of the dds files or I just need to use some additional arguments to fix this.
Hope you can help me.

I try to convert some DDS images to png. (image one, image two)
If opened in gwenview or ocular (image viewer, pdf-viewer) the dds pictures are displayed fine. So I think there must be a possibility to get around the following issue:

However, if I want to convert them, I get the following errors:
- on all resulting pictures the color of the pixels are mixed and the original image is very hard to see
- on the second one I get "unexpected end-of-file" (convert: unexpected end-of-file `ICON02.DDS': No such file or directory @ error/dds.c/ReadDDSImage/405.)

The resulting images are: result one, result two

I'm using:
ArchLinux 3.6.9-1-ARCH, KDE
ImageMagick 6.8.0-7 2012-12-06
rmagick (2.13.1) (ruby interface, however I tried both: using ruby and command line)

I would be very very happy if someone has an idea how to fix this.
I already tried different quality settings or using only one thread. The results are the same :/

Thanks in advance.
Kind regards,

edit: Fixed links
Post Reply