Unable to run commands after install

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
Posts: 1
Joined: 2013-05-20T16:58:28-07:00
Authentication code: 6789

Unable to run commands after install

Post by davehhoodpro »

I followed ImageMagick.org's instructions to compile the latest source (6.8.7) for CentOS 6.3 if they didn't support it (they only supported up to 5.8), but that had some problems and I inadvertently discovered that I could install it automatically through yum, so I ran "make uninstall" and then ran "yum install ImageMagick" (which installed an older version, 6.5.4), but now "identify" and "convert" don't work:

-bash: /usr/local/bin/identify: No such file or directory
-bash: /usr/local/bin/convert: No such file or directory

I check /usr/local and the only files in any of the folders there relate only to ImageMagick... everything else is installed in / (/bin, /etc, /lib, etc). We have an identical server that already had ImageMagick 6.5.4 (which the previous developers installed), so I think they used the yum method but I think my source install screwed that up.

Can someone offer me any advice on this? I already tried exporting variables (like MAGICK_HOME and LD_LIBRARY_PATH) according to their instructions, but that did nothing. How do I get it to install into the root directory instead of local?
Post Reply