Problem with installing Inkscape with latest Imagemagick version, Centos.

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
Posts: 45
Joined: 2013-12-10T15:14:46-07:00
Authentication code: 6789

Problem with installing Inkscape with latest Imagemagick version, Centos.

Post by eleison »

I use Imagemagick to convert images from SVG to PNG. The problem is that the RSVG is not rendering the SVG good enough. I tried using Inkscape and get required results. The problem is though when I try to install Inkscape on my server with ImageMagick 6.9.0-4 Q16 x86_64 already installed i get this error:

Code: Select all

--> Running transaction check
---> Package libXfont.x86_64 0:1.4.5-4.el6_6 will be installed
---> Package libfontenc.x86_64 0:1.0.5-2.el6 will be installed
--> Processing Conflict: ImageMagick-last- conflicts ImageMagick
--> Finished Dependency Resolution
Error: ImageMagick-last conflicts with ImageMagick-
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
So what I'm trying to do is:
yum install inkscape

I tried using "--skip-broken" but it also fails...

I got Centos 6.6 (Final) running, 64 bits.

If I do yum remove Imagemagick I can install inkscape but then I get an old imagemagick version (ImageMagick 6.5.4-7).

I would like to use latest Imagemagick with Inkscape as a delegate to render SVG to PNG on Centos.

I know this is probably a Centos focused question, but I guess there is many people in this forum using both latest Imagemagick and Inkscape at the same time.

Post Reply