Page 1 of 1

[SOLVED] Text in gif: stroke switch causes Aborted: (core dumped)

Posted: 2018-05-22T10:30:15-07:00
by jamtat
Arch user here with imagemagick installed. A script for adding text to a gif file, one I cobbled together some time ago, has stopped working recently. I get an "Aborted: (core dumped)" message when I try to run it. It's a really complex (and probably ugly) script, so I won't post the whole thing here at this time. But I have run some tests today using a similar line that was taken straight from and I get the same error message.

The command is

Code: Select all

convert -background white -fill dodgerblue -font Candice -strokewidth 2 -stroke blue -undercolor lightblue -size 165x70 -gravity center label:Anthony label_color.gif
attempting to run which also results in the "Aborted: (core dumped)" message. Subsequent fiddling with that command, as also resulted in some fiddling I'd previously done with my more complex command, seems to indicate that the -stroke switch is the source of the problem. When I remove that switch, the command runs successfully, though, of course, the resulting image does not have the additional visual effects the -stroke switch is supposed to enable.

Any ideas what could be going on here? Has Arch perhaps compiled a defective binary or some such? Has the -stroke switch been perhaps removed/replaced in more recent versions of IM? It looks like I do still have access through Arch repositories to imagemagick6 so I could go back to using it to see whether that resolves my issue. Still it would be nice to know what's the source of the issue in imagemagick .

Input will be appreciated.

Re: Text in gif: stroke switch causes Aborted: (core dumped)

Posted: 2018-05-22T10:48:56-07:00
by jamtat
Nevermind. I updated repositories today and noted that a slightly newer version of imagemagick was available: imagemagick- So I upgraded to it, and now the command listed above runs without errors. So it looks like maybe the Arch maintainer for this package might have compiled a defective binary. So, problem solved.

Re: [SOLVED] Text in gif: stroke switch causes Aborted: (core dumped)

Posted: 2018-05-22T11:24:45-07:00
by magick
The ImageMagick development team has been busy squashing security flaws in ImageMagick courtesy of OSS Fuzz. Unfortunately, these fixes, on occasion, introduce new flaws such as those in the drawing subsystem in and has resolved these flaws and drawing / clipping / masking appears to work properly once again.