PDF Conversion error

Magick.NET is an object-oriented C# interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning Magick.NET
Post Reply
Posts: 3
Joined: 2018-09-11T14:50:41-07:00
Authentication code: 1152

PDF Conversion error

Post by lucd »

found the problem in the meantime (stream read from Azure Blob storage is corrupted...)


The classic error:

IPS.Core.Exceptions.ProcessingException: no decode delegate for this image format `' @ error/blob.c/BlobToImage/457 ---> ImageMagick.MagickMissingDelegateErrorException: no decode delegate for this image format `' @ error/blob.c/BlobToImage/457
at ImageMagick.MagickImageCollection.NativeMagickImageCollection.ReadBlob(MagickSettings settings, Byte[] data, Int32 length)
at ImageMagick.MagickImageCollection.AddImages(Byte[] data, Int32 length, MagickReadSettings readSettings, Boolean ping)
at ImageMagick.MagickImageCollection.AddImages(Stream stream, MagickReadSettings readSettings, Boolean ping)
at ImageMagick.MagickImageCollection..ctor(Stream stream, MagickReadSettings readSettings)

Magick NET 7.10.1
Ghostscript 9.25
Azure web app

Sample code to create the IMagickImage from pdfs:

Code: Select all

        private IMagickImage GetMagickImage(Stream content)
                MagickReadSettings settings = new MagickReadSettings
                    FrameIndex = 0,
                    FrameCount = 1,
                    Density = new Density(200, 200, DensityUnit.PixelsPerInch)

                MagickImageCollection  magickImageCollection = new MagickImageCollection(content, settings);
                IMagickImage image = magickImageCollection.FirstOrDefault();
Various images and pdfs are processed without any error, except pdfs from a specific serie

sample file https://pimdevstor01.blob.core.windows. ... page_1.pdf

no error when running the code locally
no error with All other PDFs
tried 32/64 bits same result

Thanks to help !
Post Reply