Page 1 of 1

./configure ... make ... error

Posted: 2006-03-09T16:12:31-07:00
by riegel

I am trying to install Imagemagick 6.2.6 ./configure runs fine with no errors, but when I run make it errors almost immediatly, I am not sure how to proceed.

Here is the output from my terminal. I get the same error with 6.2.5 and 6.2.6. Should I try an older version?

Code: Select all

[ImageMagick-6.2.5]# make
if /bin/sh ./libtool --silent --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I./magick -I./wand  -I./ltdl -I./ltdl  -I/usr/include/freetype2 -I/usr/X11R6/include -I/usr/X11R6/include/X11  -g -O2 -Wall -pthread -MT magick/magick_libMagick_la-animate.lo -MD -MP -MF "magick/.deps/magick_libMagick_la-animate.Tpo" -c -o magick/magick_libMagick_la-animate.lo `test -f 'magick/animate.c' || echo './'`magick/animate.c; \
then mv -f "magick/.deps/magick_libMagick_la-animate.Tpo" "magick/.deps/magick_libMagick_la-animate.Plo"; else rm -f "magick/.deps/magick_libMagick_la-animate.Tpo"; exit 1; fi
if /bin/sh ./libtool --silent --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I./magick -I./wand  -I./ltdl -I./ltdl  -I/usr/include/freetype2 -I/usr/X11R6/include -I/usr/X11R6/include/X11  -g -O2 -Wall -pthread -MT magick/magick_libMagick_la-annotate.lo -MD -MP -MF "magick/.deps/magick_libMagick_la-annotate.Tpo" -c -o magick/magick_libMagick_la-annotate.lo `test -f 'magick/annotate.c' || echo './'`magick/annotate.c; \
then mv -f "magick/.deps/magick_libMagick_la-annotate.Tpo" "magick/.deps/magick_libMagick_la-annotate.Plo"; else rm -f "magick/.deps/magick_libMagick_la-annotate.Tpo"; exit 1; fi
magick/annotate.c: In function `RenderFreetype':
magick/annotate.c:1241: `ft_encoding_latin_1' undeclared (first use in this function)
magick/annotate.c:1241: (Each undeclared identifier is reported only once
magick/annotate.c:1241: for each function it appears in.)
make: *** [magick/magick_libMagick_la-annotate.lo] Error 1
The system is Linux

Code: Select all

[ImageMagick-6.2.5]# uname -a
Linux 2.4.9-e.62 #1 Fri Apr 8 18:36:17 EDT 2005 i686 unknown

Posted: 2006-03-09T17:08:08-07:00
by riegel
I updated freetype and it solved my problem.